BETA

27th April 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [27/04/18 04:19 PM] with 'Major Outage'

Issue has been resolved at [27/04/18 04:21 PM]