BETA

25th April 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [25/04/18 02:07 PM] with 'Major Outage'

Issue has been resolved at [25/04/18 02:08 PM]