BETA

20th April 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [20/04/18 03:22 PM] with 'Major Outage'

Issue has been resolved at [20/04/18 03:24 PM]