BETA

20th April 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [20/04/18 12:06 PM] with 'Major Outage'

Issue has been resolved at [20/04/18 12:07 PM]