BETA

5th April 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [05/04/17 05:10 PM] with 'Partial Outage'

Issue has been resolved at [05/04/17 08:01 PM]