BETA

18th April 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [18/04/18 04:57 PM] with 'Major Outage'

Issue has been resolved at [18/04/18 04:59 PM]