BETA

18th April 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [18/04/18 04:23 PM] with 'Major Outage'

Issue has been resolved at [18/04/18 04:41 PM]