BETA

18th April 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [18/04/18 10:25 AM] with 'Major Outage'

Issue has been resolved at [18/04/18 10:26 AM]