BETA

17th April 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [17/04/18 10:51 PM] with 'Major Outage'

Issue has been resolved at [17/04/18 10:52 PM]