BETA

16th April 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/04/18 02:42 AM] with 'Major Outage'

Issue has been resolved at [16/04/18 02:43 AM]