BETA

15th April 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [15/04/18 07:10 PM] with 'Major Outage'

Issue has been resolved at [15/04/18 07:13 PM]