BETA

3rd April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/04/17 11:32 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/04/17 11:34 AM]