BETA

14th April 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/04/18 02:20 PM] with 'Major Outage'

Issue has been resolved at [14/04/18 02:25 PM]