BETA

14th April 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/04/18 01:28 PM] with 'Major Outage'

Issue has been resolved at [14/04/18 01:30 PM]