BETA

14th April 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/04/18 12:51 PM] with 'Major Outage'

Issue has been resolved at [14/04/18 12:54 PM]