BETA

13th April 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/04/18 12:09 PM] with 'Major Outage'

Issue has been resolved at [13/04/18 12:11 PM]