BETA

3rd April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/04/17 11:15 AM] with 'Major Outage'

Issue has been resolved at [03/04/17 11:17 AM]