BETA

29th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [29/04/19 02:25 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/04/19 02:39 PM]