BETA

12th April 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/04/18 12:52 PM] with 'Major Outage'

Issue has been resolved at [12/04/18 12:53 PM]