BETA

9th April 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [09/04/18 05:31 PM] with 'Major Outage'

Issue has been resolved at [09/04/18 05:43 PM]