BETA

8th April 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [08/04/18 03:21 PM] with 'Major Outage'

Issue has been resolved at [08/04/18 03:23 PM]