BETA

7th April 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [07/04/18 05:02 PM] with 'Major Outage'

Issue has been resolved at [07/04/18 05:03 PM]