BETA

3rd April 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [03/04/17 10:45 AM] with 'Partial Outage'

Issue has been resolved at [03/04/17 10:46 AM]