BETA

7th April 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [07/04/18 02:10 PM] with 'Major Outage'

Issue has been resolved at [07/04/18 02:11 PM]