BETA

7th April 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [07/04/18 01:11 PM] with 'Major Outage'

Issue has been resolved at [07/04/18 01:12 PM]