BETA

7th April 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [07/04/18 11:34 AM] with 'Major Outage'

Issue has been resolved at [07/04/18 11:35 AM]