BETA

3rd April 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [03/04/17 02:21 AM] with 'Partial Outage'

Issue has been resolved at [03/04/17 02:22 AM]