BETA

6th April 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [06/04/18 04:53 PM] with 'Major Outage'

Issue has been resolved at [06/04/18 04:54 PM]