BETA

6th April 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [06/04/18 04:44 PM] with 'Major Outage'

Issue has been resolved at [06/04/18 04:46 PM]