BETA

3rd April 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [03/04/18 04:12 PM] with 'Major Outage'

Issue has been resolved at [03/04/18 04:13 PM]