BETA

3rd April 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [03/04/18 01:01 PM] with 'Major Outage'

Issue has been resolved at [03/04/18 01:04 PM]