BETA

2nd April 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [02/04/18 09:46 AM] with 'Major Outage'

Issue has been resolved at [02/04/18 09:48 AM]