BETA

1st April 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [01/04/18 05:20 PM] with 'Major Outage'

Issue has been resolved at [01/04/18 05:37 PM]