BETA

1st April 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [01/04/18 03:16 PM] with 'Major Outage'

Issue has been resolved at [01/04/18 03:17 PM]