BETA

1st April 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [01/04/18 03:04 PM] with 'Partial Outage'

Issue has been resolved at [01/04/18 03:05 PM]