BETA

31st March 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [31/03/18 12:22 PM] with 'Major Outage'

Issue has been resolved at [31/03/18 12:24 PM]