BETA

2nd April 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [02/04/17 12:03 PM] with 'Partial Outage'

Issue has been resolved at [02/04/17 12:10 PM]