BETA

30th March 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [30/03/18 02:20 PM] with 'Major Outage'

Issue has been resolved at [30/03/18 02:21 PM]