BETA

29th March 2018

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [29/03/18 11:19 AM] with 'Major Outage'

Issue has been resolved at [29/03/18 11:20 AM]