BETA

29th March 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [29/03/18 11:19 AM] with 'Partial Outage'

Issue has been resolved at [29/03/18 11:20 AM]