BETA

28th March 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [28/03/18 04:33 PM] with 'Major Outage'

Issue has been resolved at [28/03/18 04:35 PM]