BETA

28th March 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [28/03/18 02:00 AM] with 'Major Outage'

Issue has been resolved at [28/03/18 02:05 AM]