BETA

27th March 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [27/03/18 04:55 PM] with 'Major Outage'

Issue has been resolved at [27/03/18 04:59 PM]