BETA

27th March 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [27/03/18 12:22 PM] with 'Major Outage'

Issue has been resolved at [27/03/18 12:26 PM]