BETA

26th March 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [26/03/18 12:06 PM] with 'Major Outage'

Issue has been resolved at [26/03/18 12:08 PM]