BETA

24th March 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [24/03/18 09:11 PM] with 'Major Outage'

Issue has been resolved at [24/03/18 09:12 PM]