BETA

31st March 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [31/03/17 07:01 AM] with 'Major Outage'

Issue has been resolved at [31/03/17 07:02 AM]