BETA

24th March 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [24/03/18 11:40 AM] with 'Partial Outage'

Issue has been resolved at [24/03/18 11:41 AM]