BETA

25th June 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [25/06/16 03:14 PM] with 'Major Outage'

Issue has been resolved at [25/06/16 03:15 PM]