BETA

24th March 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [24/03/18 09:13 AM] with 'Major Outage'

Issue has been resolved at [24/03/18 09:14 AM]